Welcome to our community

Be a part of something great, join today!

MHB Slow

Petek

Member
Jan 8, 2013
20
For several months, all the pages on MHB take a relatively long time to load. No other site is affected. I've cleared my cookies and cache. Slowness happens both in Firefox (even with all addons disabled) and IE. My OS is Win7, x64. My system has 9GB of RAM with about 4 GB free. I assume that the problem is on my end. Otherwise there would be more reports of slowness. Any suggestions? Thanks.
 

skeeter

Well-known member
MHB Math Helper
Mar 1, 2012
639
Loads at about the same rate as other sites I visit ... no discernible slow down for either of my devices on my end. My PC runs Windows 10 and my ipad has ios 11.
 

Jameson

Administrator
Staff member
Jan 26, 2012
4,029
I think the overhead from our images is adding up. We have a lot of custom PHP/javascript code now so when you put all of that together it slows down a lot unfortunately. Let me look into pricing with Amazon for a Content Delivery Network. Thank you for the feedback.

EDIT: Apparently there is a product called vBOptimise that allows CDN integration. I'm going to look into this now. :)
 

Greg Bernhardt

Administrator
Staff member
Feb 3, 2012
129
I think the overhead from our images is adding up. We have a lot of custom PHP/javascript code now so when you put all of that together it slows down a lot unfortunately. Let me look into pricing with Amazon for a Content Delivery Network. Thank you for the feedback.

EDIT: Apparently there is a product called vBOptimise that allows CDN integration. I'm going to look into this now. :)
We use MaxCDN but honestly I'm not totally sure it's worth the money. The difference in speed is marginal. There are so many factors and free ones you can try first.
 

Jameson

Administrator
Staff member
Jan 26, 2012
4,029
We use MaxCDN but honestly I'm not totally sure it's worth the money. The difference in speed is marginal. There are so many factors and free ones you can try first.
Any recommendations for free ones to try? Right now we are using Cloud Flare but I don't think it has a huge improvement. We can move to PM or email if you would like. :)
 

Greg Bernhardt

Administrator
Staff member
Feb 3, 2012
129

MarkFL

Administrator
Staff member
Feb 24, 2012
13,735
For me, MHB's page load speed is comparable to other forums running vB3/4 and XF (although the other sites on which I am most active are also feature rich, i.e. heavily modded). :)

Even pages containing the ckeditor, where the majority of our custom code exists, is snappy. That being said, we should continue to look for ways to improve...;)
 

Jameson

Administrator
Staff member
Jan 26, 2012
4,029
For me, MHB's page load speed is comparable to other forums running vB3/4 and XF (although the other sites on which I am most active are also feature rich, i.e. heavily modded). :)

Even pages containing the ckeditor, where the majority of our custom code exists, is snappy. That being said, we should continue to look for ways to improve...;)
Mark, could you look into removing the Add This script for now? I found the source in the header template but can't seem to get it to go away. I've followed Google's suggestions and switched some of our images to be compressed versions as well.
 

MarkFL

Administrator
Staff member
Feb 24, 2012
13,735
Mark, could you look into removing the Add This script for now? I found the source in the header template but can't seem to get it to go away. I've followed Google's suggestions and switched some of our images to be compressed versions as well.
I've commented out the code in the header template which calls the external script. Are you wanting to disable the vertical panel of buttons on the left side altogether or just the actual script?

edit: I went ahead and disabled the panel as well, by commenting out the code. :)
 

Jameson

Administrator
Staff member
Jan 26, 2012
4,029
Thank you Mark. I reran the page speed link the Greg showed up and it's already improving. I'll move this conversation to a private section for the staff to discuss. I've looked at a lot this stuff before but a lot has changed since then. You've become a coding wizard and my day job now involves coding, so I think we can make more headway. :)
 

Jameson

Administrator
Staff member
Jan 26, 2012
4,029
Just so everyone knows, I've spoken to our host just now and added 2 GB of RAM to our server. This should help out with caching data and with some other plugins we might use. I assure everyone I want to make the site faster for everyone.
 

Petek

Member
Jan 8, 2013
20
Page loading time is back to normal for me. Thx to everyone who worked on this issue!
 

Joppy

Well-known member
MHB Math Helper
Mar 17, 2016
256
I have this problem also. But it seems to come and go. I posted about it here.

Currently everything is running very smooth for me. But a month or so ago everything was taking a really long time to load.

Interestingly, the symptoms seem to be the same each time. The website banner and 'Forums, Activity,...' links appear instantly, but the 'Reply to Thread' box remain unavailable for a while.

Not sure if this is useful, but thought i'd chip in :p.