Welcome to our community

Be a part of something great, join today!

[SOLVED] Error posting new visitor message

  • Thread starter
  • Admin
  • #1

MarkFL

Administrator
Staff member
Feb 24, 2012
13,775
Hello,

I ran into a problem posting a welcome VM to a new member. I am told the message is too long when it clearly isn't. I tried logging out to clear my cookies (which has alleviated other errors in the past) but the error persists. Here is a screen shot of the error:

vmerror.jpg
 

Ackbach

Indicium Physicus
Staff member
Jan 26, 2012
4,197
Try pasting your text into a word processor that can count characters. I'm curious what the actual count is.
 

Klaas van Aarsen

MHB Seeker
Staff member
Mar 5, 2012
8,887
I see you have WYSIWIG mode on.
Likely you have a lot of invisible text formatting in your message.
Click the quick button at the left top to see it.
You can click the second quick button to easily remove the formatting.
 
  • Thread starter
  • Admin
  • #4

MarkFL

Administrator
Staff member
Feb 24, 2012
13,775
I copied and pasted from a previous VM like I have done many times before with no problem. I don't have a word processor that counts characters, but it counts 43 words.
 

Klaas van Aarsen

MHB Seeker
Staff member
Mar 5, 2012
8,887
Did you check if there is any formatting?
 
  • Thread starter
  • Admin
  • #6

MarkFL

Administrator
Staff member
Feb 24, 2012
13,775
What I usually do is go to the profile page of the last person to which I sent a welcome message, and copy and paste it to the new user's profile, changing the name, and then submitting it. This has always worked fine.

I just went to the profile of the person before the last one I had sent and tried it again, and this time it worked.(Emo)

If there was any formatting, I have no idea how it was added this time and not all the others.
 

Klaas van Aarsen

MHB Seeker
Staff member
Mar 5, 2012
8,887
If there was any formatting, I have no idea how it was added this time and not all the others.
Perhaps a different browser or something like that?
It might for instance also depend on the desktop theme you're using.
WYSIWIG means that you get what you see.
A theme that shows the background slightly yellowish is probably enough to get unwanted text formatting.
I have been surprised myself what happens when I try to copy and paste text from anywhere.
Nowadays, I always have my editor set to plain text mode.
 
  • Thread starter
  • Admin
  • #8

MarkFL

Administrator
Staff member
Feb 24, 2012
13,775
I simply copy from here to here, with no intermediate word processor involved. I'm just going to chalk it up to one of the myriad of frustrations that arise from computer/internet use. :D
 

Jameson

Administrator
Staff member
Jan 26, 2012
4,052
Hi Mark. (Wave) I'm sorry that this annoying issue has found you. Can you try three things?

1) Try copy/pasting the message that you used for that user on my page and see if it works there.
2) Using a different browser try posting the message on that user's page again.
3) Using the "test" account try posting the message on that user's page again.

Thanks!
 

topsquark

Well-known member
MHB Math Helper
Aug 30, 2012
1,140
Ummm...

Should we be turning WYSIWYG off in general? I've never had problems, but if this is a good practice then I'll do it. (If I don't have it off already.)

-Dan
 

Klaas van Aarsen

MHB Seeker
Staff member
Mar 5, 2012
8,887
Ummm...

Should we be turning WYSIWYG off in general? I've never had problems, but if this is a good practice then I'll do it. (If I don't have it off already.)

-Dan
Typical symptoms we've seen before is that latex does not work for an obscure reason.
Turns out the formulas have (invisible) vBulletin formatting in them, breaking the latex engine.

If your screen looks like Mark's snapshot, you have WYSIWYG on.
If you have it off by default (in your settings), the top left quick button $\boxed{^A/\underline A}$ is pressed (blue) by default.
 
Last edited:

topsquark

Well-known member
MHB Math Helper
Aug 30, 2012
1,140
Typical symptoms we've seen before is that latex does not work for an obscure reason.
Turns out the formulas have (invisible) vBulletin formatting in them, breaking the latex engine.

If your screen looks like Mark's snapshot, you have WYSIWYG on.
If you have it off by default (in your settings), the top left quick button $\boxed{^A/\underline A}$ is pressed (blue) by default.
Okey-dokey. It's off on mine. Thanks.

-Dan
 

MarkFL

Administrator
Staff member
Feb 24, 2012
13,775
Hi Mark. (Wave) I'm sorry that this annoying issue has found you. Can you try three things?

1) Try copy/pasting the message that you used for that user on my page and see if it works there.
2) Using a different browser try posting the message on that user's page again.
3) Using the "test" account try posting the message on that user's page again.

Thanks!
1) I received the same error.
2) IE would not even allow me to paste the message.
3) I received the same error.

It seems to me that the problem lies with that particular message which I tried to copy/paste, since it worked when I copy/pasted from a different user, the one previous to the one which does not work.

edit: To test my hypothesis that some kind of "cumulative" formatting is happening, I tried copying the latest message to your profile and indeed I got the same error. So it seems to me that each time I copy and paste this message, one or more invisible characters is added, and it finally went over the limit.